Order processing delays
Incident Report for TicketCo AS
Resolved
This incident has been resolved.
Posted Apr 03, 2022 - 21:14 UTC
Identified
We are experiencing order processing delays. People may have to wait after ticket selection for a longer time. Working to resolve it.
Posted Apr 03, 2022 - 19:58 UTC
This incident affected: TicketCo cloud platform.