Ongoing Email Service Disruption Impacting TicketCo Communications

Incident Report for TicketCo AS

Resolved

Delivery delays have been resolved on the provider's side, and all emails have been sent.
Posted Mar 17, 2025 - 16:15 UTC

Update

Our email service provider is still investigating the issue, and we are actively monitoring the situation.
Posted Mar 17, 2025 - 11:49 UTC

Monitoring

We will get back with more information when we know.
Posted Mar 17, 2025 - 09:46 UTC
This incident affected: Ticket Distribution (Ticket distribution on email).