Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 30, 2026 - 04:00 UTC
Scheduled
We're applying maintenance to one of our database clusters to deliver better performance and scaling for high-traffic event days. What to expect: During the maintenance window you may see brief errors or delays — typically under a minute. Most operations continue normally; any failed requests can be safely retried.
Posted May 29, 2026 - 12:41 UTC
This scheduled maintenance affected: TicketCo Flex / Our API platform (TicketCo Flex / Profiles, TicketCo Flex / Subscriptions, Event, Public API, TicketCo Flex / Inventory, TicketCo Flex / Reservations), TicketCo Flow / Our fan journey (TicketCo Flow / Version 1.0, TIcketCo Flow / Version 2.0, TicketCo Flow / Payments, Ticket Distribution / SMS, Ticket Distribution / email), TicketCo Connect / Our integration module (TicketCo Connect / HID, TicketCo Connect / Fortress), and TicketCo Admin / Our web administration module, TicketCo Media Service / Our streaming platform (TMS), TicketCo AdminApp / Our POS solution.