Email delivery delays
Incident Report for TicketCo AS
Resolved
The issue is resolved since about one hour ago
Posted Jun 09, 2022 - 14:02 UTC
Identified
Our email distribution provider is having issues now. You may experience email delivery delays. They are working on the fix already
Posted Jun 09, 2022 - 13:08 UTC
This incident affected: Ticket Distribution (Ticket distribution on email).